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1. Introduction

DragThing is an application dock designed to tidy up the icons littering your desktop. Simply drag an 
application from the Finder onto an empty square in a dock and then drag documents onto it as normal. 
Double-click a docked application to launch it or bring it to the front. In addition, the docks can contain 
files, folders, disks and servers, and there is also a option to display the currently running processes in a 
special dock.

New in 1.6 is the ability to store and organise Internet URLs in docks and double-click them to open the 
URL with an appropriate helper application. You can drag URLs into any dock and edit them, and also 
import and export docks as HTML.

It requires at least System 7.5 (or 7.1 with Drag & Drop, AppleScript and the Scriptable Finder) and a 
Macintosh with a minimum of a Motorola 68020 or PowerPC 601 processor. Storing URLs in docks 
requires Internet Config 1.1 or later. The application is distributed as a fat binary with both regular 68K 
and native PowerPC versions included.

DragThing may be used freely - all I ask is that if you really like DragThing and keep using it, you send 
me something cool in return. There is a list of cool stuff later on to guide you. People who send me cool 
stuff have a much better chance of getting bugs fixed or requested features added, and can feel good 
about themselves. People who keep using DragThing and don’t send me anything will just have to live 
with the guilt… 

Postcards aren’t cool.
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2. Using DragThing

Most things in DragThing have Balloon Help - turn it on and point at anything you are unsure about. 
There are useful tips scattered throughout the Balloon Help messages for the menus and controls.

Also, have a look in the Preferences window shown below (select the ‘Preferences…’ item from the Edit 
menu or type Command-E) for a lot of options including showing the Process Dock and changing the 
font used in the docks. Click the name of a section in the list to show the options associated with it.

Installation

To install DragThing, put it in the Startup Items folder inside your System Folder and just double-click 
to begin. Alternatively, keep it anywhere else on your hard drive and check the ‘Open DragThing 
automatically at startup’ option in the DragThing Preferences window. This creates an alias to 
DragThing in the Startup Items folder and ensures it is up to date when the program opens.

If you get any error messages when you run DragThing for the first time, take a look at the 
troubleshooting section later on in this manual. Make sure you have Drag & Drop and the Scriptable 
Finder installed (that both come as part of System 7.5) since DragThing is unable to function without 
them. It’s a good idea to also have Macintosh Easy Open installed too, because this makes it a lot easier 
for DragThing to find out what types of files are accepted by applications.

If you want to use the Internet features, you need to install the Internet Config extension, version 1.1 or 
later, which is available at any Info-Mac archive.
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Memory Requirements

Depending on the size of your docks and the kind of Macintosh you have, you might also need to adjust 
the amount of memory given to DragThing from the Get Info window in the Finder. A Power Macintosh 
with virtual memory turned on requires a lot less memory than a regular Macintosh for example. The 
default setting is much more than most people will need, so adjust it as required.

The About DragThing window has a bar showing the amount of memory currently being used. 

If this is nearly full (the dark part of the bar is all the way over to the right as in the lower example), then 
it’s a good idea to give DragThing some more allocation to avoid getting any ‘out of memory’ messages. 
Also keep an eye on the memory bar as you add items to docks. Each new item takes up some space, and 
it’s easy to fill it all up. 

If DragThing runs out of memory, it will suggest you increase the memory allocation and give you the 
opportunity to quit. The next time DragThing is opened, it will ask you if you want to check the 
Preferences file for any problems.

Making DragThing Faster

You can speed up DragThing at the expense of extra memory and disk space by changing the following 
options in the Preferences window. They are not all enabled by default, so if you think DragThing is 
running slowly, you should check the settings.

This stores all the icons of the items stored in docks in the “DragThing Preferences” file in the System 
Folder. This means DragThing doesn’t have to fetch the icons for all the items every time it starts up, so 
it’s a lot faster at opening, but it does mean the preferences file grows by a couple of K for each item. In 
addition, if you rebuild your desktop to show a new icon for an application, you will need to rebuild 
DragThing’s store of icons by holding down Command and Option as you open DragThing.

You can reduce the time taken to redraw the docks and switch between layers by setting this option. This 
keeps a copy of the name of the item and other information in memory all the time, rather than having to 
fetch it from disk. The disadvantage is that each item in the dock will use a bit more memory. Before 
you turn on this option, make sure there is some free memory left in DragThing as described above, or 
you may get an ‘out of memory’ error.

Normally DragThing looks at all the items in the docks at startup to make sure the original items are not 
missing. If they are it draws a big red question mark over the item. This can take some time, so you can 
turn off this behaviour by setting this option. DragThing will still let you know if the original item is 
missing when you open the item in the dock.
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Creating & Adding Items to Docks

To create a new dock, simply select the item ‘New Dock…’ from the File menu. This will create an 
empty dock and open up its Dock Options window so you can set the name and anything else you wish 
to change. 

To add an item into a dock, drag the item from the Finder into an empty square on the dock. The docks 
will accept any normal files, folders, disks and servers. 

You can also drag text URLs into docks from any drag-aware application if you have Internet Config
installed. To create a new untitled URL item, select ‘New URL…’ from the File menu.

If you drag multiple items into a dock, it will put the first item in the highlighted empty square, and the 
other items in subsequent empty squares through the dock. If there are not enough empty squares in the 
dock to hold all the items, DragThing will refuse the drag.

You can also drag items between docks to move them. If you hold down option while dragging, a copy 
will be made of the items instead of moving them. If you drag a dock item into the Finder, an alias file 
will be created at the location you drag to.

Importing & Exporting Docks

You can also create docks by choosing a folder using the Import Dock item in the File menu. DragThing 
will then create a new dock and add all the items in that folder to the dock automatically. If you export 
the dock, DragThing will create a folder and save all the dock items as Finder alias files, with each layer 
of the dock in a different sub-folder.

If you are using DragThing with Internet Config, you can also select a text file containing HTML, and 
DragThing will extract all the URLs from the HTML with their titles, and create a dock for them. This is 
especially useful with things like your bookmarks file from your web browser, which is usually stored as 
HTML. You can export a dock of URLs to create a new HTML file you can open in your web browser.

If you have a dock with both URLs and normal dock items that you export, DragThing will create an 
HTML file for all the URLs inside the folder containing the alias files.

Removing Items from Docks

To remove an item, either drag it to the Wastebasket or select it and chose Clear from the Edit menu (or 
just press Delete). If you drag an item to the Wastebasket, an alias file will be created there, so you can 
drag it back into the dock if you change your mind. If you have added the Wastebasket to a dock, you 
can drag items to that as well. If you try and remove an item from the process dock, you get the option to 
quit that process.

To remove a whole dock, click the close box in the corner of the window. If there are any items in the 
dock, you will be asked if you want to delete or export them before the dock is removed.
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Layers & Tabs

DragThing allows multiple layers of items in a dock to help organise things further, with ‘folder tabs’ 
along the top of the dock to switch between the different layers. These work somewhat like folders in the 
Finder, in that you can store groups of related items together. 

Click on a tab, or drag an item from the Finder or a dock onto a tab to cause that layer to be brought to 
the front. You can add and remove layers using the menu items in the Edit menu, and show the layer 
tabs from the Dock Options window.

If you click on an item in one layer, you can drag it up onto a another layer’s folder tab which will cause 
the dock to switch to that layer, and then drag it down onto an empty space in the new layer. If you let go 
of an item on top of a folder tab, it will put the item in the first available free space in that layer of the 
dock if possible.

To rearrange the tabs, hold down option and click and drag the tab to the required position (including 
into another dock). If you drag a tab to the Finder, the layer will be exported as a folder of aliases (or an 
HTML file in the case of a layer of URLs). If you drag a tab to the Wastebasket, it will be removed.

Working with Dock Items

Once you have an item in a dock, if it’s an application you can drag files from the Finder onto it which 
will launch it if necessary and open the given files. 

You can select an item by clicking on it, and then open it, find the original item in the Finder, or open 
the Finder’s Get Info window using the commands in the File menu. For folders and disks, you can open 
the Finder’s File Sharing window using the Sharing item in the File menu.

You can also double-click the item to open it as in the Finder. From the Dock Options window for each 
dock described below, you can set the dock to use just a single-click to open items, so whenever this 
manual mentions ‘double-click’, it could be changed to ‘single-click’. When the single-click option is 
on, you can hold down Shift and click the item to just select it and not open it.

If you open an item in the Process Dock, DragThing will switch that process to the front, assuming it’s 
not a background-only process.

You can select more than one item at a time just like in the Finder, by holding down the Shift key and 
clicking more items, or by clicking in an empty place on a dock and dragging a rectangle around the 
items you want selected. 

Anything you can do to one item such as opening or deleting it, you can do to many items at once.

Page 5



Resizing Docks

To resize a dock to create new empty squares, click at the bottom or right hand side of the dock window 
(the cursor will change to show the right place) and drag the window out the the required size. Docks 
can be any size with multiple rows and columns limited only by memory.

You can change the size of the icons displayed in each dock using the items in the View menu. If you 
have lots of documents with the same icon, you can either give them custom icons to tell them apart, 
choose the Show Names option, or select them and change their colour using the Label menu.

You can also rotate the docks from vertical to horizontal and back using the Rotate Dock item in the 
Window menu. The Clean Up menu item gets rid of any empty spaces throughout the dock and moves 
all the items along. 

Minimising & Maximising

The Minimise menu item allows you to shrink a dock down to a small window containing just the dock 
title. Click on the minimised dock to expand it back to full size again.

If you drag onto a minimised dock, it will expand for the duration of the drag and shrink again 
afterwards. The position of the minimised window is remembered separately from the normal dock 
position so, for example, you can have a minimised dock at the very bottom of your screen that moves 
upwards to reveal the full dock. Just drag around the minimised dock to where you want it to be.

To make a dock automatically minimise when you switch to a different application (for example, when 
you double-click an item), set the option ‘Minimise in background’ in the Dock Options window 
described below. To make the dock automatically maximise when DragThing is brought to the front, set 
the other option ‘Maximise in foreground’.

Resizing Dock Items

To change the size of the squares used for each dock, hold down the Option key and resize the dock 
horizontally or vertically. The cursor will change as shown below to show you where to click.

The size of each square will adjust so that the dock becomes the size specified. You can do this do show 
more or less of the item names as required. You can also use this technique to change the size of the 
minimised dock window. 
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The font and size used to draw the dock item names, layer tab names, and minimised dock names can be 
set in the main Preferences window. 

If you change the font size, or pick a taller font, the size of the squares will adjust automatically.

Dock Options

If you want to rename a dock, select Dock Options from the Edit menu when it is at the front. This 
window also has options specific to each dock such as using a single click to open items. As usual, use 
the balloon help if you are unsure what a particular option does.

If you have added any extra layers to the dock, you can show the layer folder tabs here, at either the top 
or the bottom of the dock window.

If you have the items displayed without names, the ‘Show current item name’ option adds a strip along 
the bottom or top of the dock that shows the name, and optionally the full path, of the item that is 
currently under the mouse. If you point at a URL item, the location of the URL itself is displayed rather 
than the name. There are more options in the Preferences window to show the icon and filetype of the 
current item shown.
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If you like to keep a dock positioned in a particular corner of the screen, it’s worth checking the 
‘Position window relative to corner’ box and clicking on that corner on the small desktop next to it. 
DragThing then knows to always position the dock window at a particular offset from that corner, even 
if you change the screen resolution up and down repeatedly. 

Normally, DragThing will guess the corner nearest to the dock when positioning the window, but in 
cases where you have a long dock that almost touches the other side of the screen, it might not do what 
you expect unless you explicitly tell it which corner to use. This is especially noticeable with the Process 
Dock, which regularly changes its size and can touch the other side of the screen if you have a lot of 
processes running (or a small screen).

If you lock a dock, you won’t be able to add or remove items from it or change its position. Also, the 
controls in the Dock Options and Layer Options windows for the dock will be disabled.

Layer Options

For each layer of the dock, there is also an options window that allows you to set the name of the layer 
and its colour. 

If you select Layer Options from the Edit menu it will open up the options with for the current layer of 
the current dock. Alternatively, you can double-click the layer tab itself to open up the window.

Item Options

Each item has an options window that allows you to change the name of the item without changing the 
name of the original. In the case of a URL, it also allows you to change the URL and enter comments.
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Colours

You can change the colour schemes available in the Layer Options window using the Colours section of 
the Preferences window.

This allows you to change the main dock colour (middle), along with the highlight and shadow colours 
(left and right) used to give the docks a 3D look, and the name of the colour scheme. Click on a colour to 
bring up the standard colour picking dialog window. When you change a colour, all the docks that use it 
will show the new one immediately. 

Click the ‘Reset to factory colours’ button to change all the colours and names back to their original 
settings.
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3. Troubleshooting

(or “it’s not a bug, it’s a feature”)

If an unexpected error occurs in DragThing, it should bring up an Alert and give you the chance to quit 
or continue. If you can reproduce the problem, send email to the address below detailing what causes it 
along with the error ID number and the line number and source file where it occurs.

If you have any problems such as the correct icons not appearing, or the applications not accepting 
documents when you drag them on, rebuild the desktop on your hard disk (by holding down command 
and option as the Finder starts up). DragThing relies on a correct Desktop Database for many things, so 
this is a likely source of problems. If you have the ‘Cache Icons in Preferences File’ option on, also hold 
down command and option as DragThing starts up to rebuild the DragThing cache to see any new icons. 
The information about which files are accepted by applications is also held in this cache.

I can’t make DragThing come to the front during a drag. The Drag Manager disables process switching 
during drags so it isn’t technically possible.

Some files that have icons in the Finder won’t have icons in DragThing such as sound files, drag 
clippings, GX stuff and AOCE stuff - these are all special cases in the Finder and not available through 
the Desktop Database. Also, some files and folders like the Wastebasket don’t really exist at all and are 
just made up by the Finder to confuse innocent programmers. And don’t get me started about Desktop 
Printers either…

DragThing requires the Scriptable Finder which comprises the Finder (at least version 7.1.4) and the 
Scriptable Finder Extension. If you turn off extensions by holding down the shift key at startup, the 
Finder loses its scriptable nature and DragThing won’t work. Also, DragThing uses the Scriptable Finder 
to do things like open files and applications so if you quit the Finder you won’t be able to do much. 
DragThing will ask you if you want to restart the Finder if you try and do something that requires it. The 
one exception to needing the Finder is that if you have the Finder itself stored in a dock, you can double-
click to launch it regardless.

If you Mac suffers a really bad crash and writes random memory over DragThing, it’s possible the 
DragThing Preferences file may be corrupted and you will get an error the next time DragThing starts 
up. Since version 1.0.2, DragThing keeps a backup copy of the Preferences automatically and will revert 
to that if necessary. Since version 1.5, DragThing will attempt to detect and fix any problems it finds 
with the Preferences file. Since version 1.6,  DragThing will know if you crashed and will offer to check 
the Preferences for problems when you next start up.

If you have Optimem installed, the memory bar reportedly claims you aren’t using any memory. I 
believe that one of the things Optimem does is pretend to the application that it has more free memory 
than normal, so this isn’t surprising.

There are problems with dragging files that already exist to CAP network volumes. For some reason the 
Finder will also ask if you want to replace the files after DragThing does, despite being told not to. This 
is either a CAP or a Finder bug.

There have been reports of a rare crash on opening DragThing on a PowerMac, after quitting an old 
version and immediately starting up the new one, especially if the machine has been up and running 
DragThing for many days without restarting. It is recommended that you quit the old version and restart 
your machine before running the new version (not forgetting to remove any startup aliases). After 
restarting, everything works normally. This is believed to be a bug in the system software, which seems 
to have been fixed in 7.5.3, but tread carefully.

DragThing will probably crash on an original 68000 based Macintosh, such as a Plus, Classic or 
PowerBook 100. Since it requires 32-bit Color QuickDraw, which doesn’t work on a 68000 either, 
DragThing has been compiled for a 68020 processor. One person has complained about this so far, but I 
have no plans to support earlier machines or older versions of the System Software.
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4. Secret Tips & Shortcuts

Modifiers Keys

To open the Finder Get Info window for an item, hold down Control and double-click the item.
To open the surrounding Finder window for an item, hold down Command and double-click the item.
To remove an item or quit a process, hold down Control and Command and double-click the item.
To select an item when the ‘Use single-click to open’ option is on, hold down Shift and click the item.
To drag a dock without using the titlebar, hold down Option and click an empty area on the dock.

Keyboard Shortcuts

To navigate round a dock, use the arrow keys or type the name of an item to select it directly.
To open the selected items, press Return/Enter.
To cycle forwards through the docks press Tab (or Command-Up Arrow) and Shift-Tab 
(or Command-Down Arrow) to cycle backwards again.
To switch layers, hold down Command and press the Left and Right Arrow keys.
Command-0 selects the Process Dock, and Command-1 to Command-9 selects the other docks.
To remove an item or quit a process, click on it and press Delete, select Clear from the Edit menu, 
or drag it to the Wastebasket.

Dragging

Hold down Option when you drag an item between two docks to make a copy instead of moving it.
Hold down Option when you drag a file to a folder or disk item to make a copy instead of moving it.
Hold down Control when you drag a file to a folder or disk item to make an alias instead of moving it.
To make an alias to an item, drag the item into the Finder.

Windows

To open the Dock Options window for a dock, hold down Option and select it from the Window menu.
To open all the Layer Options windows for a dock, hold down Option and Shift and select it from the 
Window menu.
To close all the non-dock windows, hold down Option and close one of them.
To resize the dock item squares and minimised docks on a per dock basis, hold down Option and 
resize the dock.

Docks, Layers & Items

To export all the docks at once, hold down Option and select ‘Export All Docks…’. from the File menu.
To rearrange the folder tabs, hold down Option and click and drag the tab to the required position.
To open the Options window for a layer, double-click the folder tab for that layer.
To change the icon for a dock item, select it and paste an icon copied from a Finder ‘Get Info’ window, 
or another dock item.

Preferences

DragThing will open a preferences file in the same folder as itself before looking in the main Preferences 
folder in the System Folder for one.
To rebuild the DragThing icon cache, hold down Command and Option as DragThing starts up.
To force the preferences file to be checked for problems (useful if you get an error message at startup), 
hold down Control and Option as DragThing starts up.

About DragThing

To go to the DragThing web page, click the DragThing logo in the About window.
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5. Version History

This is a major new release of DragThing with some cool Internet features added. In addition there are 
speed increases and a lot of user interface enhancements and new options. Please give a copy of this 
version to anyone you know that uses DragThing.

The DragThing web page is now available at <http://www.dcs.gla.ac.uk/~james/dragthing.html> and it 
should always have the latest version and information. If you have Internet Config installed, just click 
the DragThing logo in the About DragThing window to go there automatically.

1.6

Now you can drag URLs into docks and double-click them to open with Internet Config installed.
Now you can import HTML files to create docks of URLs and export them to HTML again.
Now you can rearrange the layer folder tabs by dragging and can move layers between docks.
Now you can change the name of dock items without changing the name of the original.
Now you can copy and paste custom icons for dock items.
Added option to double the speed of drawing docks showing item names by caching data in memory.
Added option to double the speed of startup by not checking for bad dock items.
Added options to show the full path, icon and filetype of the current item at the bottom of the dock.
Added option to use the real system WDEF (and worked round a problem caused by Aaron 1.3 ).
Added option to turn off zoom rects.
More routines for detecting and fixing problems with the Preferences file.
Much faster live dock window growing.
Much smarter hot corners on multiple monitor systems.
New about window with links to the DragThing web page.
New preferences window with multiple pages of options.
Lots of user interface enhancements and some other new options and bug fixes.
Recompiled with Metrowerks C/C++ 1.4.5.

1.5.1

Fixed -50 error at startup when a process with a custom icon was running.

1.5

Added multiple layers to docks with folder tabs to switch between them.
Added option to show the name of the item under the cursor at the bottom of the dock window.
Added option to cache the icons of dock items & other data in the Preferences file for faster startup.
Added option to highlight the running processes in all docks.
Added window to edit the colour schemes.
Added Label menu for dock items.
Added ‘Find…’ button to the missing file alert box.
Added ‘Launch Finder’ button to the ‘Finder not running’ alert box.
Now a dragged dock window will snap to the edges of the screen and other docks when close.
Now you can select and drag more than one dock item at a time just like in the Finder.
Now with live dock window growing.
Now you can resize the dock item squares and minimised docks on a per dock basis.
Now the process dock shows custom icons and labels for running applications.
Now icons for stationery files show up properly.
Now alert boxes and dialogs appear on the correct screen with multiple monitors.
Now hot corners work on multiple monitors.
Now full slot clicking can be set independently of single-click setting.
Now holding down command and control while clicking an item removes or quits it.
Now easier to localise into different languages.
Documentation rewritten and now distributed in eDOC & PDF formats with an Apple Guide file.
Various other minor (and not so minor) changes.
Recompiled with Metrowerks C/C++ 1.4.
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1.1

Now can change the dock font and size.
Now can change the dock colours.
Now can hide dock window titlebars and show dock names in the titlebar.
Now titlebar position can be changed independently of dock orientation.
Now you can type the name of an item to select it like in the Finder.
Now position of dock windows can be stored relative to a specific corner.
Now accepts files dragged from Find File and other applications.
Added Window menu to switch between docks (with command-key shortcuts).
Added Import and Export commands to load and save a dock as a folder of alias files.
Changed the Dock Options window to include the single-click and minimise/maximise options.
Fixed crashing bug when dragging items into the Finder.
Fixed bug with folder icons being corrupted.
Fixed bug causing a phantom click when clicking on a minimised dock in the background.
Fixed bug in window positioning after a resolution switch.
Yet more minor application and documentation changes.
Recompiled with Metrowerks C/C++ 1.3.

1.0.2

Now keeps a backup copy of the Preferences file. 
Now checks for missing dock items at startup and flags them with a red question mark over the icon.
Changed dock WDEF to System windoid style with zoom box to minimise/maximise docks.
Changed Dock Options dialog into a non-modal window.
Fixed potential problem when getting custom icons from files.
More minor application and documentation changes.

1.0.1

Now you can drag items in docks onto other items in docks.
Added new large icon with name view.
Dragging multiple items to an empty square in a dock will add them all if there is enough space. 
Added experimental ability to lock docks.
Fixed bug in window positioning on multiple monitors.
Fixed crashing bug when opening the Preferences window on some Macs.
Some other minor application and documentation changes.
Recompiled with Metrowerks C/C++ 1.2.1.

1.0

First public release.
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This version of DragThing will expire a year from its release date, on the 1st of May 1997. It will start to 
annoyingly remind you about this a month earlier. There should be a new version available by then from 
the Info-Mac and Umich archives or from whoever gave you this copy. Check the DragThing web page 
<http://www.dcs.gla.ac.uk/~james/dragthing.html> for the latest information. If you have Internet 
Config installed, DragThing will offer to take you there a month before it is due to expire.

I’ve done this to stop old versions floating round for years to come rather than a “pay the shareware fee 
now” thing. But, having said that, if you send me something cool and include an email address, I can 
keep you notified of new versions as they appear and send you them via email if you want. 
Unfortunately, I don’t have the time to send out copies by regular mail, even if you send me blank disks 
and large bags of money.

The most recent version will always be sent directly by me to macgifts@mac.archive.umich.edu so it 
should appear on the Info-Mac and Umich archives and all other good Macintosh ftp sites and their 
mirrors automatically. Hopefully it will also be kept up to date on places like AOL by people uploading 
it on my behalf. If you see old versions lying around on these and other sites, you are encouraged to send 
them the new one.

DragThing is written using Metrowerks CodeWarrior.

6. About The Author

The author is currently working as the resident Macintosh guru in the Systems Development Group at 
the Computing Science Department of the University of Glasgow. He specialises in Macintosh 
development and systems management and also has a nice sideline in Unix systems administration.

Regular viewers will note that since graduating with a BSc Honours degree in Computing Science from 
the department in July 1994, he hasn’t left the building yet. He now makes major purchasing decisions 
and gets a lot more junk mail. As ever, he eventually wants to work for Apple, but is quite happy 
working for Sony Computer Entertainment Europe in the meantime. Only he doesn’t.

Email: james@dcs.gla.ac.uk
WWW: http://www.dcs.gla.ac.uk/~james/

At Home: 25 Dumbreck Road, Glasgow, Scotland, G41 5LJ, The UK.
At Work: Department of Computing Science, University of Glasgow, Scotland, G12 8QQ, The UK.

7. Legal Stuff

Don’t put DragThing on your CD-ROM or magazine cover without getting prior permission. That’s not 
cool. I’ll probably say yes if I get sent a copy or subscription, but do ask first. I don’t want the first thing 
I know about DragThing being on the cover disk of a magazine is finding it in my local newsagent… 
Naming no UK Mac magazines with a readership of over 45,000 of course. Ahem.

If you want to distribute DragThing with a commercial product, let me know and we’ll come to some 
arrangement. Individuals are encouraged to freely distribute DragThing and upload it to online services 
but commercial distribution is not permitted. For-profit shareware/PD software libraries are specifically 
prohibited from including DragThing on their disks, but genuine user groups are allowed to if they get 
permission first. This documentation and the unmodified application must be included with any 
distribution. And don’t strip out the PPC or 68K code either…

While DragThing may be distributed in the above cases, it is copyright and not in the public domain. I 
retain all rights to DragThing. DragThing comes with absolutely no warranty at all. It may cause all sorts 
of horrible things to happen to your Macintosh. You don’t have to use it. If you live in a country where 
my liability for any problems caused directly or indirectly by DragThing cannot be so reduced to 
nothing, you may not use this software. Have a nice day!
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8. Cool Stuff

To help you decide what to send me in return for DragThing, here is a list of some things that are 
officially considered cool. If you work for a cool company send me something they make or some of 
their promo stuff. If you work for a magazine, write me a review. Be imaginative - send me something 
you’d enjoy finding in your mail in the morning! Students and others working in education or for non-
profit organisations are allowed to just send cool email…

If in doubt, send a t-shirt!

What Is Considered Cool

1. T-shirts (medium preferred) - see the list below!
2. Pin badges.
3. CDs (black or silver)
4. Magazine subscriptions/books/media
5. Movie scripts
6. Musical instruments
7. Animation cells
8. Puzzles
9. Neat technology
10. Developer tools

What Is Considered Really Cool

1. A blue Sony PlayStation (with developer kit)
2. A Copland DR1 (or a trip to WWDC96)
3. Apple/Sony/Metrowerks shares
4. A PowerPC Platform machine running MacOS and Solaris
5. A global television/video game standard

The Really Really Wanted T-shirt List

1. A Sony PSX or SCE t-shirt from the US/Europe launch
2. An Industrial Light & Magic t-shirt (the white one with the triangle logo)
3. Something to wear to WWDC 96 (or WWDC97 at this rate…)
4. An RSA Perl t-shirt (tricky one :-)
5. Some CodeWarrior geekware
6. A Sega Saturn, Sonic or Nintendo 64 t-shirt
7. A Pixar/Toy Story t-shirt
8. Any other sad computing and technology related t-shirts…

The Coolest Things So Far

1. A platinum Apple pin badge in a silk pouch
2. An original animation cell from the credits of the Pink Panther movie
3. An Apple bow tie that plays ‘Jingle Bells’
4. A flute
5. Almost being nominated for the UMPA programming awards (11th nominee out of 10…)
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10. Thanks

Dair for running the first ever version and supplying cool toys (and not getting to go to WWDC either).
Pete for insisting on running the early versions and giving initial encouragement.
Iain for never being satisfied with any version but running it anyway and to Mark, the voice of insanity.
Naveed, Barbara and Norman for running DragThing and not complaining much.
Jonathan for buying lunch and keeping me right on dereferencing (contractual obligatory thanks).
Mike for still talking to me (everybody wish Mike a happy birthday).
Duncan for joking about adding the URL features (anyone for a DragThing Lite?).
Jon for putting up with me saying “…but it says you should have 11 pixels of white space there…”

Rick Holzgrafe for much useful help and suggestions (despite being a bitter rival :-)
Troy Gaul for suggesting many features and doing cool Apple things.
Bryan K. “Beaker” Ressler for the cool stuff and major encouragement.
Sak Wathanasin for sending the first bit of cool stuff.
Tonya Engst for writing the first cool review. 
David Pogue for using the word “gorgeous”.
Michael Hecht for the _IconDispatch bug workarounds.
Jens Alfke for preferring Malph.
The Apple DTS sample code wizards for already writing every function I needed.

Everyone at Apple for making the Macintosh so I didn’t have to spend my life hacking Wintel™ code.
Everyone at Metrowerks for making CodeWarrior and having the best technical support in the business.
Everyone at SCE for the PlayStation - not strictly related to DragThing, but very, very cool anyway.

Thanks to all the beta testers without whom DragThing would have been released months ago. In no 
particular order… 

Chris Aguinaldo, Greg Anderson, Thomas Baker, Jonathan Bauer, Bruce Barrett, Phil Barrett, Bengt 
Baverman, David C. Black, Bob Boonstra, David Bourbon, John Boswell, Joel Brogniart, Tim Burrow, 
Travis Butler, Robert Cassidy, Scott Clausen, Jim Correia, Stephen Cronin, Paul Cunningham, Vince 
Darley, Gilles Dignard, Mark Dunlop, Bob Edmiston, Dave Ely, Phyllis Evans, Lee Fyock, Mark D. 
Gerl, Jason Grossman, Scott Gruby, Tuomas Hakkarainen, Anthony R. Harris, Richard Hess, John 
Hetherton, Sue Honig, Paul C. Hunter, Robin Jackson, Tony Jacobs, Duncan Jamieson, Jeremy Jones, 
Simon Kidd, Narayanan Lakshmanan, Mark Lanett, Gordon Laurie, Christopher Linn, Marc Liyanage, 
Peter Loron, Michael H. Martel, Colin McKane, Ed Mechem, Garner R. Miller, Erik Moon, Nelson 
Morris,  Bill Mullen, Barry Nathan, Jim Niemann, Scott Panzer, Art Parmet, Andrea Pessino, Mike 
Pinkerton, Aaron Platt, David Pogue, Marc Rawoens, Brian Reichow, Moe Rubenzahl, Kristian 
Schjelderup, Paul Schreiber, Erik Schwiebert, John Selhorst, Jason Snell, Bruce Stidston, Josh Stratton, 
Caleb Strockbine, Paul L. Suh, Toshi Takeuchi, Jay Thomas and Michael Whitney.

Dedicated to S.D.K. for letting me bring chaos to her order…

Copyright ©1994-1996 James Thomson. All Rights Reserved. Commercial Distribution Restricted.
DragThing is a TLA Systems production.
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